System Status Update – EU Region

Incident Report for Check Point Services Status

Resolved

Incident was only in one specific area which being managed
Operation of EU region is full at this point
Posted Aug 01, 2025 - 07:31 UTC

Investigating

We are currently investigating an issue causing slow device responses in specific cases within the EU region. This appears to affect a subset of users and not the entire user base. Our team is actively working to identify the root cause and resolve the issue as quickly as possible.

We appreciate your patience and will provide updates as we learn more.
Posted Aug 01, 2025 - 05:26 UTC
This incident affected: Harmony Mobile (Harmony Mobile - EU Region).