SaaS Security Outage

Incident Report for Check Point Services Status

Resolved

This incident is resolved.
Posted Jul 05, 2026 - 11:27 UTC

Investigating

We are currently investigating the issue.
Posted Jul 05, 2026 - 10:24 UTC
This incident affected: Check Point SAAS Protect (Check Point SAAS Protect - EU Region, Check Point SAAS Protect - CA Region).