Harmony Connect - Cannot start new trials
Incident Report for Check Point Services Status
Resolved
This incident has been resolved.
Posted Apr 13, 2021 - 12:17 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 13, 2021 - 10:08 UTC
This incident affected: Harmony Connect (Harmony Connect - Roaming users to Internet Access).