Harmony Email & Office 2.0 degradation
Incident Report for Check Point Services Status
Resolved
This incident has been resolved.
Posted Apr 12, 2021 - 13:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 12, 2021 - 13:15 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 12, 2021 - 12:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 12, 2021 - 11:59 UTC
Investigating
Office365 customers in Europe may experience issues with email delivery or issues with security enforcement.
Our teams are investigating the issue.
Posted Apr 12, 2021 - 11:17 UTC
This incident affected: Check Point Harmony Email & Office 2.0 (Cloud MTA).