Infinity Playblocks - US region issues

Incident Report for Check Point Services Status

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 21:08 UTC

Identified

Due to an ongoing issue with Amazon Web Services (AWS) in the US-EAST-1 region, you may experience limited functionality on Playblocks.
Posted Oct 20, 2025 - 14:44 UTC
This incident affected: Infinity Playblocks (Infinity Playblocks - US Region).