NDR SaaS service is experiencing a temporary outage
Incident Report for Check Point Services Status
Resolved
Unexpected failure while performing maintenance on service
Posted May 29, 2024 - 08:52 UTC
Investigating
We are still investigating this issue.
Posted May 29, 2024 - 07:51 UTC
This incident affected: Infinity NDR (Infinity NDR - EU Region).