Harmony SASE: US Data Residency: Admin Platform Pages Fail to Load Intermittently

Incident Report for Check Point Services Status

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 06:57 UTC

Monitoring

Issue was mitigated.
We are monitoring the system
Posted Sep 01, 2025 - 17:36 UTC

Update

We identified the root cause and investigating the ways to resolve it.
This may also impact access to ZTAs via saved bookmarks on the platform page. Connectivity (HSASE Agent) remains unaffected, and the issue is limited to our US Data Residency.
We will provide further updates as we continue our investigation.
Posted Sep 01, 2025 - 15:40 UTC

Update

Investigation is ongoing
Posted Sep 01, 2025 - 14:23 UTC

Investigating

We are witnessing errors on a back end service that results in intermittent difficulties loading sections in the web\admin platform, including invoke of network changes. Users connectivity is unaffected.

We are investigating the issue further and will provide an update shortly.
Posted Sep 01, 2025 - 13:19 UTC
This incident affected: Harmony SASE Services - US Data Residency (Infrastructure Provisioning, Management Web-Console).