Identity and Trust - Temporary Service Disruption on US region

Incident Report for Check Point Services Status

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 15:52 UTC

Investigating

We are currently experiencing partial service disruptions. The issue is under investigation.
Posted Apr 27, 2026 - 14:12 UTC
This incident affected: Check Point Identity (Identity and Trust - US Region).