Connectivity to ERM Service

Incident Report for Check Point Services Status

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 06:53 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2025 - 04:07 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 20, 2025 - 03:59 UTC

Investigating

We are currently investigating this issue.
Posted Mar 20, 2025 - 03:07 UTC
This incident affected: External Risk Management.