There is an issue Contacting Threat Emulation service in UAE region

Incident Report for Check Point Services Status

Resolved

This incident has been resolved.
Posted Mar 01, 2026 - 20:41 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 01, 2026 - 20:02 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 01, 2026 - 19:59 UTC

Investigating

We are currently experiencing communication issues in the UAE region caused by an AWS outage. As a temporary mitigation, we are in the process of rerouting affected traffic to an alternate region. We will provide further updates as the situation develops.

affecting the following products: Harmony email, Harmony endpoint, and Quantom products using the region.
Posted Mar 01, 2026 - 19:04 UTC
This incident affected: ThreatCloud AI (SandBlast Threat Emulation Cloud - Dubai, UAE).