We are continuing to monitor for any further issues.
Posted Mar 02, 2026 - 10:37 UTC
Update
We are currently experiencing a service disruption in our data center in the United Arab Emirates due to an issue with our cloud infrastructure provider. As a result, customers whose Harmony Endpoint services are hosted in the United Arab Emirates region may experience difficulty accessing the Harmony Endpoint management portal. There is no security impact. Endpoint protections on devices continue to operate as expected. Our team is actively monitoring the situation and working closely with our cloud provider to restore full service as quickly as possible. We will provide an update once the issue is resolved or if additional information becomes available
Posted Mar 02, 2026 - 07:14 UTC
Update
The service disruption in the United Arab Emirates region has been resolved, with one remaining issue related to log visibility.
The Harmony Endpoint management portal is now fully accessible. Connectivity between Endpoint clients and the server has been restored. Customers may still experience missing or delayed logs in the portal. Our team is actively working to fully restore log visibility.
We will provide another update once the remaining issue is resolved.
Posted Mar 01, 2026 - 23:55 UTC
Monitoring
We are currently experiencing a service disruption in our data center in the United Arab Emirates due to an issue with our cloud infrastructure provider. As a result, customers whose Harmony Endpoint services are hosted in the United Arab Emirates region may experience: • Difficulty accessing the Harmony Endpoint management portal • Temporary connectivity issues between Endpoint clients and the server There is no security impact. Endpoint protections on devices continue to operate as expected. Our team is actively monitoring the situation and working closely with our cloud provider to restore full service as quickly as possible. We will provide an update once the issue is resolved or if additional information becomes available
Posted Mar 01, 2026 - 17:13 UTC
This incident affects: Check Point Endpoint Security (Check Point Endpoint Security - UAE Region).