Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 09, 2025 - 16:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 06, 2025 - 16:13 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 06, 2025 - 16:10 UTC
Scheduled
We will perform a maintenance activity on our US data residency platform for the duration of 2 hours.
During this maintenance activity, we will upgrade several core services in our infrastructure to enhance overall resiliency and introduce new capabilities.
During the maintenance window, the Harmony SASE platform and user connectivity will remain operational, while some users with older agent versions may experience intermittent delays throughout the scheduled time frame.
Posted Mar 06, 2025 - 16:08 UTC
This scheduled maintenance affected: Harmony SASE Services - US Data Residency (Infrastructure Provisioning, Networking and Routing).