Delays in dashboard data updates - US & EU regions

Incident Report for Check Point Services Status

Resolved

This incident has been resolved.
Posted Jul 16, 2025 - 10:56 UTC

Investigating

We are currently working on resolving the issue.
Posted Jun 22, 2025 - 08:44 UTC
This incident affected: Harmony SAAS (Harmony SAAS - US Region, Harmony SAAS - EU Region).