Portal Access Harmony Mobile in EU

Incident Report for Check Point Services Status

Resolved

We found the issue - all operations should be working now
Posted Jul 23, 2025 - 16:13 UTC

Investigating

We are investigating
this only Affect UI
Posted Jul 23, 2025 - 14:19 UTC
This incident affected: Harmony Mobile (Harmony Mobile - EU Region).