Infinity XDR is unavailable in UAE region

Incident Report for Check Point Services Status

Identified

XDR detection services are operational.
We are still waiting for the cloud services to become operational in UAE for the portal access.
Posted Mar 03, 2026 - 16:04 UTC

Investigating

Due to major outage in AWS UAE region's datacenter the Infinity Portal (and the Infinity XDR application as part of it) is unavailable until further notice
Posted Mar 03, 2026 - 14:31 UTC
This incident affects: Check Point XDR (Check Point XDR Threat Hunting UAE Region).