Infinity portal DNS disruptions

Incident Report for Check Point Services Status

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 22:37 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 10, 2026 - 22:23 UTC

Identified

A bypass mechanism was implemented
Posted Feb 10, 2026 - 22:20 UTC

Investigating

AWS is experiencing a major DNS disruption.
https://health.aws.amazon.com/health/status?path=open-issues
We are exploring bypass options.
Posted Feb 10, 2026 - 21:55 UTC
This incident affected: Check Point Portal (Check Point Portal EU Region, Check Point Portal US Region, Check Point Portal AU Region, Check Point Portal Canada Region, Check Point Portal UAE Region, Check Point Portal UK Region, Check Point Portal India Region, Check Point Portal Singapore Region).