Maintenance in EU

Incident Report for Check Point Services Status

Resolved

This incident has been resolved.
Posted Feb 22, 2025 - 21:45 UTC

Investigating

Maintenance in the EU region, some of the tenants are not available
Posted Feb 22, 2025 - 18:04 UTC
This incident affected: Harmony Mobile (Harmony Mobile - EU Region).