Threat Emulation - Degraded Performance in Europe Data Center
Incident Report for Check Point Services
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 11:22 UTC
Investigating
Some users might suffer from degraded performance, our teams working on it.
Posted Mar 12, 2020 - 08:42 UTC
This incident affected: Check Point Cloud Services (Check Point SandBlast Threat Emulation Cloud).