Degraded performance of queries in US region

Incident Report for Check Point Services Status

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 09:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 31, 2025 - 20:26 UTC

Investigating

We are currently investigating. You may experience some queries failing.
Posted Mar 31, 2025 - 19:11 UTC
This incident affected: Infinity Portal (Infinity Portal Data Services (DataTube)).