Smart-1 Cloud is not available in UAE region

Incident Report for Check Point Services Status

Update

We are continuing to work on a fix for this issue.
Posted Mar 03, 2026 - 16:04 UTC

Update

AWS is still working on it internally and estimating at least one more day before returning power.
We are continuing to be in contact with AWS on this matter
Posted Mar 02, 2026 - 06:44 UTC

Identified

Due to Infrastructure issues in AWS UAE region, Smart-1 Cloud customers in UAE data residency may experience degraded service and difficulties. We are working to mitigate that.
Posted Mar 02, 2026 - 00:00 UTC
This incident affects: Check Point Smart-1 Cloud Security Management (Check Point Smart-1 Cloud Security Management - UAE Region).