Threat Emulation services Slowness in US

Incident Report for Check Point Services Status

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 18:52 UTC

Monitoring

We identified an internal communication error between services and have applied a fix. We're now monitoring as things return to normal.
Posted Aug 25, 2026 - 18:46 UTC

Identified

We are continuing to investigate the issue, we do see some relief and response times are starting to get back to normal.
Posted Aug 25, 2026 - 18:36 UTC

Investigating

We're investigating an issue causing slower response times. We'll share updates as we learn more.
Posted Aug 25, 2026 - 17:34 UTC
This incident affected: ThreatCloud AI (SandBlast Threat Emulation Cloud - North Virginia, USA).