Threat Emulation Cloud - Degraded Performance in Europe data center
Incident Report for Check Point Services
Resolved
This incident has been resolved.
Posted Jan 13, 2020 - 14:01 UTC
Investigating
We are currently investigating this issue
Posted Jan 13, 2020 - 10:20 UTC
This incident affected: Check Point Cloud Services (Check Point SandBlast Threat Emulation Cloud).