Harmony SASE: Slowness in Israel-1 Region

Incident Report for Check Point Services Status

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 12:49 UTC

Monitoring

We've observed signs of recovery in the israel-1 region, and performance appears to be gradually improving.
Our team continues to monitor the situation closely to ensure full stability
Posted Mar 31, 2025 - 11:50 UTC

Investigating

We are currently investigating an increase in reports of slowness affecting the Israel-1 region. Our team is looking into the issue with the highest priority.
We will provide updates as soon as more information becomes available
Posted Mar 31, 2025 - 11:07 UTC
This incident affected: Harmony SASE Regions (Israel).