Infinity Portal Data Services - EU region disruption

Incident Report for Check Point Services Status

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 18:42 UTC

Identified

Intermittent delays in query results and data updates may occur
Posted Mar 25, 2026 - 18:00 UTC
This incident affected: Check Point Portal (Check Point Portal Data Services (DataTube) - EU region).