User Center service disruption

Incident Report for Check Point Services Status

Resolved

This incident has been resolved.
Posted Apr 26, 2026 - 10:16 UTC

Investigating

We are currently investigating an issue causing the User Center and Support Center to be unavailable. Our team is working to restore service as quickly as possible.
We will provide updates as soon as more information becomes available.
Posted Apr 26, 2026 - 09:59 UTC
This incident affected: Check Point Web Sites (UserCenter / PMAP, Support Center).