UAE Infinity Portal Outage

Incident Report for Check Point Services Status

Update

We are continuing to monitor the situation as it develops.
AWS team expects to see improvements to core services in the coming hours.
Posted Mar 04, 2026 - 07:38 UTC

Identified

We are in contact with AWS and monitoring the situation.

AWS latest relevant update:
Mar 02 1:36 PM PST: "expect this to take at least a day to fully restore power and connectivity"
Posted Mar 02, 2026 - 09:38 UTC

Investigating

Due to Infrastructure issues in AWS UAE region,
Infinity Portal customers in UAE data residency may experience degraded service and difficulties.

We are working to mitigate that.
Posted Mar 02, 2026 - 07:00 UTC
This incident affects: Check Point Portal (Check Point Portal UAE Region).