Check Point CloudGuard SaaS - partial outage on the portal
Incident Report for Check Point Services Status
Resolved
This incident has been resolved.
Posted May 22, 2019 - 12:12 UTC
Investigating
Some customers may experience issues access Check Point infinity portal
Posted May 22, 2019 - 09:55 UTC
This incident affected: Harmony Email & Collaboration.