degraded performance in updates.checkpoint.com
Incident Report for Check Point Services
Resolved
This incident has been resolved.
Posted 7 months ago. Apr 06, 2018 - 14:02 UTC
Investigating
We are currently investigating this issue.
Posted 7 months ago. Apr 06, 2018 - 08:00 UTC
This incident affected: Check Point Cloud Services (Check Point Updates Service).